Welcome to the Tiki Central 2.0 Beta. Read the announcement
Celebrating classic and modern Polynesian Pop

Tiki Central 2.0 - The Beta / Bugs

Firefox-Specific bugs (Fixed)

Pages: 1 3 replies

3
3vab posted on Wed, Mar 16, 2022 7:53 PM

Couple things I've noticed on Firefox that doesn't seem to be a problem in Chrome:

  • Had to run through like 6 re-Captchas for password reset through login.
  • Modals don't submit. The modal button switches to "submitting..." and hangs. This happens with login and post submit/reply.
  • Login doesn't work at all from the modal. I have to actually be on /login.php to get the login to work.
  • Login sessions don't persist.

Edit: Chrome wants a captcha in order to post, even after login. I suspect that the captcha isn't coming up correctly in Firefox from a modal form, leading to the submission hanging.

[ Edited by 3vab on 2022-03-16 19:55:22 ]

[ Edited by leevigraham on 2022-03-17 00:49:41 ]

I'm using Firefox dev edition.

I think there are some issues with hCaptcha rendering… possibly due to the javascript integration.

I'll try and debug it. đź‘Ť

Login sessions don't persist

I need to take a look at this as well. I think deployments are killing the session… or the cookie is expiring in 60 minutes without being refreshed.

3
3vab posted on Wed, Mar 16, 2022 8:41 PM

Got it, it's on my end. I've got security/privacy extensions, and the XSS controls were preventing hCaptcha from displaying properly. Usually just allow-all for a domain solves it, but disabling NoScript entirely solved it.

Pages: 1 3 replies